FreeBSD: Java в браузерах Mozilla Firefox, Chromium, Epiphany и Opera

OpenJDK Как и в описанном ранее случае с Flash, свежеустановленные браузеры Mozilla Firefox, Chromium, Epiphany и Opera для FreeBSD не поддерживают Java. Я не могу сказать, что добавление поддержки Java к любому из указанных браузеров является сложной задачей, однако из-за существования массы устаревших мануалов процесс поиска подходящего «рецепта» в лучшем случае может затянуться на достаточно продолжительное время, а в худшем — закончиться без получения ожидаемого результата.

Краткая историческая справка

В момент моего знакомства с FreeBSD в роли десктопной операционной системы для обеспечения поддержки Java в браузерах Mozilla Firefox, Konqueror и Opera лучше всего подходил плагин из пакета Diablo JDK 1.6 или его аналог из пакета JDK 1.6, собранного с опцией [X] WEB Enable the browser plugin and Java Web Start. Со временем перечисленные браузеры перестали поддерживать данные плагины, в связи с чем пришлось заменить их плагином из пакета OpenJDK 6, собранного с опцией [X] WEB Enable the browser plugin and Java Web Start. И, наконец, совсем недавно IcedTea-Web стал самостоятельным пакетом. В настоящее время только он позволяет обеспечить полноценную поддержку Java в последних версиях браузеров Mozilla Firefox, Chromium, Epiphany и Opera для операционной системы FreeBSD. Продолжить чтение »

FreeBSD: Flash в браузерах Mozilla Firefox, Chromium, Epiphany, Konqueror и Opera

Flash По умолчанию такие браузеры, как Mozilla Firefox, Chromium, Epiphany, Konqueror и Opera для FreeBSD «отказываются» воспроизводить Flash-ролики, предлагая установить бесплатный плагин Adobe Flash Player. Так в чем же проблема? В том, что плагин Adobe Flash Player для FreeBSD попросту не существует. Неужели данное обстоятельство может стать причиной для отказа от просмотра мультимедийного контента в браузерах Mozilla Firefox, Chromium, Epiphany, Konqueror и Opera на десктопе с FreeBSD? Конечно же, нет!

Введение

Один из возможных способов воспроизведения Flash-роликов в браузерах Mozilla Firefox, Chromium, Epiphany, Konqueror и Opera для FreeBSD состоит в использовании NPAPI-плагина Adobe Flash Player, предназначенного для работы в среде Linux. Вы можете найти в Сети множество мануалов на эту тему, однако в подавляющем большинстве случаев практика покажет, что они уже утратили свою актуальность. После настройки Flash на собственном компьютере с FreeBSD я написал первую версию данной статьи, которая касалась браузеров Konqueror и Mozilla Firefox и чуть позже Opera. В связи с тем, что статья вызвала значительный (естественно, по меркам данного блога) интерес, было решено не только полностью обновить ее, но и добавить в список браузеров быстро набирающий популярность Chromium и хорошо знакомый пользователям GNOME Epiphany. Продолжить чтение »